User Tools

Site Tools


framed2018:framed_editor
 
 

frameD Editor

This is an overview of the frameD editor and the implemented functionality.

The list on the very left is the clipboard, next to it is the X-Sheet, it showing the frames in the sequence and the images assigned to them.

The preview shows the image at the currently selected frame.

Underneath the preview is the current frame slider (as well as a matching numeric input).

The tabs at the bottom right contain the menus which offer various options to edit, load and save sequences or change the way images are displayed.

The editor will load the last used project when the editor is launched and an automatic backup is found, asking the user first. No data can thus be lost by exiting it.

The automatic backup is saved on exit, if there are frames assigned to the X-sheet.

If you'd like to start with a blank project, make sure to use “New…” in the editor prior to exiting it1).

X-Sheet (list view in the middle)

The X-Sheet displays a list of frames and the images they contain.

The X-Sheet highlights both the current frame as well as frame selections.

Current Frame

The current frame is highlighted using a slightly brighter row background. This is the same frame as the one selected by the frame slider underneath the preview.

The Image pop-up under the frame slider allows you to change the image used by the current frame.

Frame Selections

The X-Sheet also allows you to select entries directly by clicking on them. This is independent of the current frame that is displayed in the preview.

Selected frames are displayed using a brighter colour to display the text.

Alt-left-click will select a frame and directly open a pop-up to select an image (this is identical to the Image pop-up described further below).

Multi-selection with shift- or ctrl-left-click combinations are also possible to drag items.

Shift-click will select all images from the last selected one to the one clicked on.

Ctrl-click will toggle the selection state of the item.

Frame Dragging

Selected items can be dragged to another position.

By default, the first selected item will be swapped with the target of the drop operation.

If shift is pressed while dragging, they will then be deleted from their original positions (a move operation). The dragging indicator will switch to red to indicate move mode.

If ctrl is pressed while dragging, then the selected items will be copied without erasing the original entries (a copy operation). The dragging indicator will switch to green to indicate the copy mode.

While dragging, the start of the dragging operation will be highlighted using a light grey frame.

Right Click Menu

Often used functions are available by right clicking on the X-Sheet.

Insert Before Selected Frame(s) This will insert an empty frame before the selected frame(s).
Insert After Selected Frame(s) This will insert an empty frame after the selected frame(s).
Remove Frame(s) This will remove the selected frame(s).
Cut / Copy / Paste Cut or copy the selection. Paste will happen on the current frame.
Please see the section on the Edit Tab for further details.
Clear Clears the selected frames.

Clipboard (list view on the left)

This displays the current content of the clipboard after a cut/copy operation. Nothing can be selected here, this list is just for informational purposes.

Frame slider

The slider allows you to set or scrub to the current frame in the X-Sheet.

Image

The image pop-up allows you to set the image for the current frame in the X-Sheet.

You can also set it to (none) – in this case the first image that precedes the current frame will be used.

Images can be loaded using the (load image) option. Multiple images may be selected.

If one image is selected and frameD detects it as being part of a sequence, then it will prompt for a range of frames of that sequence to load.

This automatic detection works if only one frame is selected (it can be any frame of the sequence) and the frame numbers are at the end of the file name, before the extension. i.e. “textSequence0001.png”

Existing frames will be overwritten.

Project Tab

Load...

This will load an existing project into the frameD editor, clearing the current one.

It can load both IFL and XFD files.

Save

This will save the current project without prompting the user.

If the current project is a new project or the editor just started, then the user will be prompted for a file name.

If the project is used in the current LightWave 3D scene, then it will be updated there as well.

Save As...

This will save the current project either as a XFD or IFL file, prompting for a file name. Either of them can be loaded into LightWave 3D using the included frameD animation loader.

If the project is used in the current LightWave 3D scene, then it will be updated there as well.

Export...

Exports the current project as an IFL file

New...

Clears the project to start a new one.

Flush unused

This removes all images that are not used in the current sequence.

Create Proxies...

Opens a window to select proxy sizes. This will create them in a single operation and store them on disk. This isn't necessary as the loader will automatically create and save proxies, but it can speed up the very first time a sequence is loaded in Layout.

Help...

Currently displays the keyboard shortcuts as well as mouse options for the X-Sheet. The help panel may remain open as a reference while you continue to work in the editor.

About...

Display the version number of frameD as well as the build date.

Edit Tab

Copy

Copies the currently selected frames into the “clipboard”. The current contents of the clipboard is displayed as a third column in the X-sheet.

Cut

Copies the currently selected frames into the “clipboard” and then clears them in the x-sheet. The current contents of the clipboard is displayed as a third column in the X-sheet.

Paste

Paste the contents of the clipboard into the x-sheet. The first frame to copy to is determined by the currently selected frame.

Clear

Clear the currently selected frame(s) from the x-sheet.

Undo

Undo the last edit(s) in the x-sheet. Only edits to the x-sheet are stored on the undo stack.

Redo

Redo the undo step2). Redos are available immediately after undos, but are cleared if further editing takes place.

Settings Tab

A change of the preview start/end or the sequence length will clear the current selection of frames in the x-sheet.

Preview Start

Set the start frame to display in the x-sheet to limit the scope and focus of edits.

Preview End

Set the end frame to display in the x-sheet to limit the scope and focus of edits.

Last X-Sheet Frame

This sets the length of the sequence as displayed in the X-Sheet. If the new length is shorter than the previous one then excess frames will be deleted. However, there is also a warning before that happens.

If the length is extended then new, empty frames will be added at the and of the X-Sheet.

Image Preview Tab

These are general, non-project specific settings.

However, currently they are saved with the project.

Preview X-Sheet only

If this is checked the preview displays the image stored in the selected frame. If the current frame contains no image, nothing will be displayed.

When not checked, it displays the image for the frame selected in the X-Sheet. If the current frame contains no image, the image from the earliest frame that contains one will be displayed.

Essentially, images are “held” until a new one is set in the X-Sheet.

This corresponds to the behaviour of the frameD loader as well as LightWave's behaviour when loading image sequences.

Sync to Layout

The current time is synced with Layout. If you scrub in Layout then the current frame in the frameD editor will change as well.

The reverse doesn't work. Scrubbing in frameD doesn't change the current frame in Layout.

Solid Background

Draw the background in the preview using either a solid colour or checks. This is only visible outside the current image or when the image contains an alpha channel.

Checker Colour

This defines the colour of the checks if the Solid Background option is off.

Background Colour

This defines the background colour in the preview.

Display Alpha Channel

If this option is enabled then the alpha channel3) of the current image will be taken into account when displaying it.

1)
We agree that this behaviour isn't quite optimal. It is certainly bound to change in future revisions, at least by making it an option.
2)
Undoes the undo?
3)
Obviously only if the current image actually contains an alpha channel.
framed2018/framed_editor.txt · Last modified: 2017/12/27 10:40 by lightwolf